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QuarterMaster Version 1.0

QuarterMaster Version 1.0 was written in VISUAL BASIC in January 1992 by Kevin McQuiggin. 
This program is Copyrighted 1992 by the author and may be distributed only as indicated below. 

MS-DOS, Visual Basic, and Windows are trademarks of Microsoft Corporation. WordPerfect is a 
trademark of WordPerfect Corporation.

Feedback and suggestions are welcomed and may be directed to the author as follows:

CompuServe: 
CSID 70661,563

Mail:
Kevin McQuiggin
5415 Smith Ave.,

Burnaby, BC
V5H 2K5
Canada

If you are an amateur radio operator I can also be reached on packet radio. My E-mail address is:

VE7ZD@VE7KIT.#VANC.BC.CAN.NA

Distribution

QuarterMaster is distributed under the "Shareware" concept. As such, if you find this program 
useful, kindly support further development of it and other programs by sending $10.00 to the 
author at the address listed above. This will register you as a QuarterMaster user and entitle you 
to notification of future upgrades.

Feel free to distribute this program to others, as long as you include the entire contents of the 
QMASTER.ZIP file, including this documentation.
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Introduction

Welcome to QuarterMaster Version 1.0, a shareware home inventory program for Windows 3.0 
and above. QuarterMaster provides you with a convenient way to record your valuables.

Use QuarterMaster to record the contents of your home, place the inventory file on a floppy disk, 
and store it in your safe deposit box or at another secure location. You can print a report for your 
own records or for your insurance company. 

Inventory contents may be copied to the clipboard for pasting into other software packages.



Installation

I suggest that you create a separate sub-directory for QuarterMaster. Alternatively you can place 
the application in a directory shared with other Windows applications. Make sure that the chosen 
directory is part of the DOS "Path=" statement in your AUTOEXEC.BAT file.

Copy the following files to the chosen sub-directory:

QMASTER.EXE
QMASTER.INI

QMASTER.HLP
VBRUN100.DLL

SAMPLE.INV

These files, with the exception of the sample inventory file, must be present for QuarterMaster to 
run properly. You can use the Windows file manager to move these files from the floppy to your 
destination directory. 

Once the files have been moved into the chosen sub-directory, QuarterMaster is ready to run.  
Choose Run... from the program manager File menu and type QMASTER.EXE for the 
application name.

You may wish to use the Windows setup facility to install QuarterMaster to an application group of
your choice. From the Main group select Windows Setup, then choose Options/Set up 
Applications/Specify an Application...; and finally specify QMASTER.EXE as the application to 
set up. Be sure to include the path to the directory where the QuarterMaster files have been 
installed. Quartermaster includes it's own icon and will be placed in your "Windows Applications" 
group by default.



Starting QuarterMaster

To start QuarterMaster from the program or file manager, choose File/Run and specify 
QMASTER.EXE as the application name.

If you have used the Windows Setup facility to create a QuarterMaster icon as descibed above, 
just double click on the icon and the program will start. Make sure that the QMASTER.INI file is in
the same directory as QMASTER.EXE or you will see a warning message. Details on setting up 
or modifying your QMASTER.INI initialization file are given below.

The main inventory form will then be displayed. You will be ready to enter household items into a 
new, empty inventory file.

How to Exit

To leave QuarterMaster and return to the program manager, choose File/Exit from the main form.
If the current inventory file has changed since it was last saved, you will be asked if you want to 
save your changes. To save the file, choose Yes and specify an inventory file name. See below 
for more details.



The Main Form

QuarterMaster operation revolves around the main form, which is shown below:

The fields on the main form are Make, Model, Serial #, Value, Type, Colour, and Description. 
These fields describe each item in your inventory. A collection of items may be saved in an 
inventory file. Each field, with the exception of the Value field, may contain any combination of 
characters. The Value field is limited to numeric characters only.

The Type and Colour fields represent the item type and colour of the inventory item. Notice that 
each of these fields has a "drop down" box. Click on the down arrow beside the field and you will 
see a set of standardized values for item type and colour. To select a value from the drop down 
list, just click on the desired item type or colour. The chosen value will automatically be copied 
into the field box. If more type or colour values exist than can be contained in the drop down box, 
use the scroll bar on the right hand side of the box to move up and down amongst the standard 
values.

For the Type and Colour fields you may also type in a value if this is desired. Thus you are not 
limited to the standardized values in the drop down box.

The contents of each drop down box are controlled by the QMASTER.INI file. They may be 
customized for your personal preference. See "The QMASTER.INI File" below for more 
information.

With the exception of the Value and Description fields, up to twenty characters may be entered 
and stored in each field. The maximum value for the Value field is $99999.99, and item 
Descriptions may contain up to eighty characters.

Text can normally be entered into each of the fields on the main form in either upper or lower 
case. If you would like QuarterMaster to automatically convert entered text to upper case, select 
Use Upper Case from the Options menu. Text entered into a field will change to upper case 
automatically when the cursor leaves the field. To turn off upper case conversion, deselect 
Options/Use Upper Case.

The main form also contains four command buttons: Next, Previous, Add, and Delete. These 
buttons function as follows:

The Next command button displays the next inventory record in the current file. If you are 
currently at the last record, clicking the Next button does nothing. A message will appear 
indicating "At last record". If you wish to add a new record, use the Add button.

The Previous command button moves to the previous inventory record. Again, if you are 
currently at the first record in the file, clicking the Previous button has no effect. A message "At 
first record" will appear to tell you so.

The Add button adds a blank record to the end of the inventory file and moves to the new record. 
You can then enter a new item into your inventory. Use the Options/Statistics... menu to display 
information summarizing the contents of your file.

Lastly, the Delete command button deletes the current inventory record. You will be prompted to 



confirm the deletion unless you have disabled this confirmation using the Options/Confirm 
Deletion menu. Once deleted, an inventory record is irretrievably lost, so use this button with 
care.

Any of these command buttons may be selected without using the mouse by pressing the Tab key
to move the focus to the desired button. Using the keyboard instead of the mouse while entering 
a lengthy inventory can speed your data entry.



File Functions

The File menu provides you with facilities necessary to store and retrieve inventory files. Use 
Open..., Save..., and Save As... to load and save your inventory files. Inventory files have the 
default filename extension of .INV. When specifying the name of an inventory file the .INV is 
optional. QuarterMaster will add it if it is not specified. 

The Load Inventory form appears when you click Open... to open an existing inventory file:

Use the Drive, Directory, and File List boxes to select an inventory file to open in the usual 
Windows manner. If you know the name of the file you wish to open, you may elect instead to 
type the it into the File Name: box. 

Double clicking on a file name in the file list box is the same as selecting the file and clicking OK. 
Shortcut keys are available for use of the form without a mouse. Use the Alt key to access the 
menus and the Tab key to move between boxes on the form.

Note that on the Load File form the only files reported available are .INV files. If you save your 
inventory under another filename extension, you must type the full file name into the File Name: 
box on the Load File form.



A sample inventory file, SAMPLE.INV, is included with QuarterMaster. Practice loading, 
modifying, and saving this file to get an idea of how the program works.

To save the current inventory file to disk, use the File/Save... or File/Save As... menus. Save... 
saves the current file under it's current name, while Save As... saves the current file under a new 
name. The first time an "Untitled" file is saved, QuarterMaster acts as if you selected Save As... 
and prompts you for the file name. The file name dialog box appears as follows:

Enter the file name and click OK. Click Cancel to return to the main form without saving. 

Saving an inventory file under a file name that already exists will overwrite the old file. The 
contents of the old file will be lost.

Use the New command on the File menu to clear out the current inventory file. If the file has 
changed since last being saved you will be prompted to save your changes first.

The File menu also provides you with options to Print your inventory, and Exit back to Windows. 
Print... displays a dialog box as described below. Exit will prompt you to save your inventory if it 
has changed since it was last saved.



Printing a Report

To print an inventory report, choose File/Print... from the main form. The report dialog box as 
shown below will be displayed. Next choose the fields from the current inventory file that you want
included in the report. Use the mouse to place an 'X' in the desired fields. If you want to report on 
all fields, click on the All command button at the bottom of the form.

Once you have selected which fields you wish to print, click on the Print command button. The 
selected information will be queued to the print manager and printed. Once the report has been 
generated you will see a confirmation message. Click OK to return to the main form.

The printed report includes the current date and time as well as a summary of the inventory, 
including total value of all items.

Store your report with the diskette containing your inventory, or send a copy to your insurance 
company.



Searching for Records

QuarterMaster provides you with a number of ways to retrieve information that you have entered 
into an inventory file. You can search for Make, Model, Serial Number, item Type, or Description. 
There is also an option that allows you to move directly to a particular record if you know the 
record's location.

To begin a search of the current inventory file, select Search from the main form and click on the 
desired search type. A dialog box will appear asking you to enter the field contents that you wish 
to search for. Enter the desired value and click on the OK button or press ENTER. QuarterMaster
will search the inventory for the entered information. If a matching record is found, an information 
box will appear to indicate that a match has been found, and the main form will display the 
located record. If no matches were found, a dialog box will appear telling you so. You may then 
start a new search.

If a matching record was found, additional matches can be found by clicking on Search/Next 
Match, or by pressing the F3 function key. Additional matches are displayed as above.

You may begin a new search at any time by selecting the new search type from the Search 
menu.

Searches normally are length and case insensitive. This means that a match will be detected if 
any part of the inventory field matches the search text. For example, if the search text is entered 
as 'art', then QuarterMaster will report a match on any inventory record containing 'art', but also 
on 'Art', 'article', 'Artisan', and 'Party', that is, any inventory record containg the string 'art' as part
of the chosen field.

To limit your search to exact matches of the search text, check 'Exact Match' on the Search 
menu before starting your search.

To move to a record at a specific location in your inventory file, select Go To Record... from the 
Search menu. A dialog box will ask you which record you wish to display. Enter the desired 
record number and press ENTER. The specified record will be displayed. If the record number 
does not exist, a warning message will appear. Click OK to begin another search.



Sorting your Inventory File

QuarterMaster allows you to sort an inventory file into ascending or descending order. You can 
elect to sort by any of the following fields: Make, Model, Serial #, Value, or Type.

To sort an inventory file into ascending order by serial number, choose Order/Serial # from the 
main form. Note that ascending order is the default, as indicated by the Ascending/Descending 
check mark items on the bottom of the Order menu. To change to descending order, click on 
Order/Descending.

Once Serial # is selected, QuarterMaster will rearrange the inventory records into ascending 
order by serial number. The record position will be moved to the start of the file, and the first 
record will be displayed. Use the Next command button to verify that the records are now in 
ascending order by serial number.

To sort the inventory file on any of the other fields, choose that field from the Order menu. Use 
the SAMPLE.INV file and experiment with sorting on different fields and on ascending and 
descending order. Attempts to sort an empty inventory file will generate a warning message.

Be sure to use File/Save... to save the rearranged contents of the inventory file should this be 
desired.



View Options

The main form displays data from the current inventory file one item at a time. Sometimes it is 
convenient to view your inventory in the form of a table, with all items listed one per line. To 
switch from the main form to a list configuration, choose View/List from the main menu. A new 
form will be displayed which shows the entire contents of the inventory file one item per line. 

Each item's Description field is listed beyond the right of the form and may be displayed by using 
the scroll bar at the bottom of the screen. Use the vertical scroll bar to scroll up and down in your 
inventory file. The Inventory List form appears as follows:

At the end of the inventory records a summary line shows the total number of records and their 
total value.

To return to the main form select File/Return from the menu.

A useful feature of this display format is that of allowing the displayed inventory information to be 
copied to the Windows Clipboard. This allows the inventory to be accessed by other Windows 
applications. To copy the inventory to the clipboard choose Copy/Copy to Clipboard from the 
main menu.

It is not possible in this version of Quartermaster to paste existing clipboard contents into an 
inventory file.



File Statistics

The Options/Statistics... selection on the main form presents statistical information on the 
current inventory file. Current file name, number of records, file size, and total inventory value are 
included. This information may be useful before saving the current file onto a diskette.

Click OK to return to the main form.

On Line Help

Use the Help menu to display QuarterMaster help information.

QuarterMaster Version 1.0 provides only limited on line help facilities. These are in the form of a 
text file that can be scrolled to locate the desired topic. Future versions of the program will contain
more complete help.

The Help menu also contains program credits under the About... form. Click OK to return to the 
main form.



The QMASTER.INI File

QuarterMaster has it's own initialization file, QMASTER.INI, which contains the choices available 
to the user for the item Type and Colour fields on the main form.

The contents of this file are in ASCII format and thus can easily be customized using any text 
editor, such as Edlin, MS-DOS Edit, or Windows Notepad. Although word processing packages 
such as WordPerfect may be used to edit the QMASTER.INI file, be careful to ensure that the 
edited file is saved in ASCII format, and not in your word processor's internal format. Files saved 
in a non-ASCII format will not be recognized properly by QuarterMaster.

QMASTER.INI is laid out in a format similar to the Windows initialization files WIN.INI and 
SYSTEM.INI. There are two sections, [type] and [colour]. The [type] section contains a list of 
available property types, which will be displayed by the Type drop-down box on the main form. 
The [colour] section contains the list of standard colours. These appear in the Colour drop-down 
box on the main form. The spellings [colour] and [color] are interchangeable, and either section 
may be omitted if desired. The two sections must be separated by a blank line, and entries within 
each section may be in any order. QuarterMaster automatically sorts the entries into alphabetical 
order before displaying them in their respective drop-down boxes.

A sample QMASTER.INI file is as follows:

[colour]
WHI
YEL
GRN
BLU
RED
BLK

[type]
Coin
Jewellery
Sporting Equipment
Tool
Appliance
Art
Gun
Electronic
Other

This file should be stored in the same directory as QMASTER.EXE.



In Case of Difficulty

Should you experience problems of a nature not covered in this manual, contact the author via 
CompuServe, mail, or amateur packet radio. Contact information is in the first section of this 
manual.

I will try to fix any reported problems and supply you with an updated version of QuarterMaster. I 
cannot, however, accept any responsibility for loss of data or any other loss that may result from 
use of the program. The best safeguard against loss of data is to perform regular backups.

Thanks for trying QuarterMaster!


